Results 1 to 3 of 3

Thread: Nexus 5 ADB error "Device Offline", how to fix it?

  1. #1
    Junior Member
    Join Date
    Sep 2013

    Nexus 5 ADB error "Device Offline", how to fix it?

    I am trying to root Nexus 5. I got a new Android L rom for the same. But when I try to use adb commands I am getting a device offline message. I had tried to reconnect the my device a number of time but the error is constant. It is not going. I had changed the usb ports also.

    I had tried to do all possible things from my end but nothing is working. I want a bit help here to make this thing work. I cannot even install custom recovery. My cable is not faulty. I am using the same for another phone where it worked well.

  2. #2
    Senior Member
    Join Date
    Oct 2012

    Re: Nexus 5 ADB error "Device Offline", how to fix it?

    The issue is due to USB Drivers. But you can resolve that.

    For the simplest way is to turn on USB Debugging and then connect the phone to pc. When you turn it on the system will automatically give you a popup for usb drivers. Most of the time this is installed automatically but sometime you have to find the same on web. You can download the Google Nexus Drivers from here. Install that and then test back. There are adb universal drivers. Test them also. This are commonly used in adb method.

  3. #3

    Re: Nexus 5 ADB error "Device Offline", how to fix it?

    Another thing you can do is try to verify the current Google USB Driver. When you connect the phone by turning on usb debugging, go in Device Manager. And see whether the drivers are added or not. If you find any hardware with exclamation mark on the same then it means it is not installed. You have to add that back again.

    You will have to find drivers for Android Composite ADB Interface that is an essential component to run adb flash.

Similar Threads

  1. Replies: 2
    Last Post: 29-06-14, 10:49 PM
  2. Karbonn S5 Rooting error "Your device is read only try trick"
    By D-man in forum Smartphone & Portable Fixes
    Replies: 2
    Last Post: 05-04-14, 06:48 PM
  3. Unable to install Win 8.1 "Getting Device ready"
    By Abbudin in forum Operating Systems
    Replies: 3
    Last Post: 22-01-14, 12:06 AM
  4. Replies: 1
    Last Post: 14-01-14, 02:33 AM
  5. Lumia 920 error "MTP USB device has a driver problem"
    By Arular in forum Smartphone & Portable Fixes
    Replies: 3
    Last Post: 12-10-13, 05:42 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

About TechDiscussion is an Open Source Community to provide latest information from Technology World, provide instant help for users tech related issues, we provide free downloads for your Computers, Smartphones, and more...

Follow us on

Twitter Facebook youtube RSS Feed Flickr DavianArt Dribbble