Welcome to TechDiscussion Forums


Your one stop community for Technical Assistance


  •  » Need latest Tech Updates?
  •  » Looking for Windows Troubleshooting?
  •  » Want some optimization Tips for Smartphone?
  •  » Or any other Technology discussion?

...You have come to the right place!


we will try to help you with your problem.


YES! I want to register an account for free right now!


p.s.: For registered members TechDiscussion.in is free of ads

Results 1 to 3 of 3

Thread: How to Overclock Intel I7 2700k on Asus Maximus Extreme-z Mobo

  1. #1
    Junior Member
    Join Date
    May 2012
    Posts
    25

    How to Overclock Intel I7 2700k on Asus Maximus Extreme-z Mobo

    HI, I am having a computer with Asus Maximum Extreme-z motherboard, Intel Core i7 2700k, Intel Z68 chipset. It has Speed steeping and turbo boosting technology to overclock your CPU. I disable the Speed steeper and turbo boosting mode, Increased the CPU frequency to Overclock the CPU but when I reach to 4 GHZ turbo boosting and Speed steeping mode get turned On itself. I tried doing it again but yet the same result, they tun on automatically. And due ti that am not able to complete the overclocking process. I don’t know why is it happening, no idea. Can you guys please help me doing this properly ? Any help will be appreciated.



    •   Alt Ads!

      TechDiscussion
       

  2. #2

    Re: How to Overclock Intel I7 2700k on Asus Maximus Extreme-z Mobo

    Even am not pro in overlocking but still will try to help you. Whenever you do overclocking the cpu, I guess your turbo boosting and speed steeping should be enabled. You are you disabling them ? Also you can manually set your CPU frequency to 4.4 GHz. You will find two things related to turbo setting where one is “Turbo Ration” and second is “Maximum Turbo Ration” in BIOS. Simply put 44 in both to overclock your CPU to 4.4 GHz. Am not sure about this but you should try it out if anyone else confirms this.

  3. #3

    Re: How to Overclock Intel I7 2700k on Asus Maximus Extreme-z Mobo

    Am not getting the cause behind this problem. Even I have Asus Maximum Extreme-z and I overclocked sucessfully to 4.3 GHz. Anyways, just try this out.

    • Reboot your system and go to BIOS
    • Go to AI tweaker section and set Manual to AI Overclock Tuner.
    • Then set the turbo ratio to 44.
    • Set the CPU voltage to manual and put the CPU manual voltage is 1.22v.
    • Save all setting and restart your computer


    Now check in CPU-Z and enjoy your performance. Don’t Overclock your RAM frequency because it may effect to your performance as well.

Similar Threads

  1. Asus launches a 7inch 3G Tablet ‘Asus FonePad’
    By Dr. Technical in forum Laptop & Tablets Fixes
    Replies: 4
    Last Post: 29-04-13, 12:20 PM
  2. Intel CPU vs. AMD CPU
    By Boreanaz in forum Polls & Voting
    Replies: 3
    Last Post: 09-08-12, 03:02 PM
  3. Replies: 1
    Last Post: 07-06-12, 12:47 AM
  4. How to Overclock Processors
    By !!Master!! in forum Guides and Tutorials
    Replies: 1
    Last Post: 01-04-12, 01:28 PM
  5. Price list of Intel Motherboard
    By mylife in forum Hardware Peripherals
    Replies: 0
    Last Post: 14-12-11, 12:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About TechDiscussion

    TechDiscussion.in is an Open Source Community to provide latest information from Technology World, provide instant help for users tech related issues, we provide free downloads for your Computers, Smartphones, and more...

Follow us on

Twitter Facebook youtube RSS Feed Flickr DavianArt Dribbble