Results 1 to 3 of 3

Thread: Wi-Fi drops after every 10 minutes on Toshiba C50D-A-13G after installing Windows 10

  1. #1

    Wi-Fi drops after every 10 minutes on Toshiba C50D-A-13G after installing Windows 10

    I am unable to figure out what mistake I had done while I was upgrading my system to Windows 10. My friend gave me the DVD of this new OS.

    I thought this will be great to upgrade the same. But later on once all things were over; I had notice a frequent internet connection dropping problem. And this happened in a internal of every 10 minutes. I came to know about this when I was streaming a video from YouTube.

    Want some help to fix the same.

  2. #2

    Re: Wi-Fi drops after every 10 minutes on Toshiba C50D-A-13G after installing Windows 10

    It looks like a driver problem to me. Right click on My Computer > Properties. Then click on Hardware and click on Device Manager. Just go in that and see the wifi adapter. Right click on that and choose update drivers. You can also find that on Toshiba site under the driver update page. Get the latest updates drivers and test it. I am quite sure after adding a new drivers the problem will be resolved and you will be able to use it.

  3. #3

    Re: Wi-Fi drops after every 10 minutes on Toshiba C50D-A-13G after installing Windows 10

    Just for testing purpose connect your pc to your modem/router with LAN cable. And then verify the same. If the internet connection still drop then it is possible the issue is with the internet provider.

    You have to contact your ISP for fixing the problem. Most of the times reconnecting your wifi connection fix the issue. The connection will also drop if your laptop is too far from the router. There must be a decent distance.

Similar Threads

  1. Replies: 0
    Last Post: 30-10-14, 03:18 PM
  2. HP 630 laptop turns off within two minutes after turning on
    By NewUser in forum Laptop & Tablets Fixes
    Replies: 2
    Last Post: 13-09-14, 03:50 PM
  3. How to track Applications price drops on Play Store
    By Steinbach in forum Smartphone & Portable Fixes
    Replies: 4
    Last Post: 02-07-14, 05:20 AM
  4. Windows 7 won't install on Toshiba U405, Error code 10 and code 37
    By RA-One in forum Laptop & Tablets Fixes
    Replies: 4
    Last Post: 13-04-12, 06:11 PM
  5. Application starts after 10 minutes in Motorola Milestone
    By Sn0w_Le0p@rd in forum Smartphone & Portable Fixes
    Replies: 1
    Last Post: 25-03-12, 08:31 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About TechDiscussion

    TechDiscussion.in is an Open Source Community to provide latest information from Technology World, provide instant help for users tech related issues, we provide free downloads for your Computers, Smartphones, and more...

Follow us on

Twitter Facebook youtube RSS Feed Flickr DavianArt Dribbble