Welcome to TechDiscussion Forums


Your one stop community for Technical Assistance


  •  » Need latest Tech Updates?
  •  » Looking for Windows Troubleshooting?
  •  » Want some optimization Tips for Smartphone?
  •  » Or any other Technology discussion?

...You have come to the right place!


we will try to help you with your problem.


YES! I want to register an account for free right now!


p.s.: For registered members TechDiscussion.in is free of ads

Results 1 to 3 of 3

Thread: Enabling 128-bit encryption on Internet Explorer 11

  1. #1
    Junior Member
    Join Date
    Nov 2013
    Posts
    12

    Enabling 128-bit encryption on Internet Explorer 11

    Can anybody here please tell me how to enable encryption on Internet Explorer 11. I want to turn this thing on due to some sites which are asking for the same. I need option to turn on 128-bit high encryption. I cannot find any setting inside the browser. I am quite sure this is going to work but how to do the same?

    When I click on a site it ask me for the same. I click on continue and then I get a message that your browser ha to b upgraded for the same. It is not having the 128bit encryption support. I am using the latest version of Internet Explorer here.

    Thanks in advance for your helps.

  2. #2

    Re: Enabling 128-bit encryption on Internet Explorer 11

    Internet Explorer is known for various bugs and issues. I will recommend you to switch your browser. This will be more easier for you to resolve the issue you are facing.

    And if you want to be with IE than you have to install the required update in your system. For which you have to go on the official site and download the most latest version of IE or any latest update which your system is not having. And then you can try back to open that site. Go with Firefox. I think that will work well with all type of site.

  3. #3
    Senior Member
    Join Date
    Aug 2012
    Posts
    164

    Re: Enabling 128-bit encryption on Internet Explorer 11

    This thing is never disabled, It remains ON by default. You have to just open the site which is asking for the encryption. But if that is not working then it means your version is outdated. There is no exact settings through which you can enable and disable this. What more you can do is reset IE settings and then try back. Resetting will put the browser on the default mode.

    And you can do that from Internet Options > Tools > Security. Just try this out. If that does not help much then you can try using Firefox.

Similar Threads

  1. PDF files won't work on Internet Explorer 11
    By MartiNeau in forum Internet & Web Browsers
    Replies: 2
    Last Post: 03-07-14, 10:16 PM
  2. Internet explorer 11 won't allow me to print
    By Sabhya in forum Internet & Web Browsers
    Replies: 2
    Last Post: 15-05-14, 11:59 PM
  3. Top Features of Internet Explorer 11
    By !!Master!! in forum Reviews
    Replies: 1
    Last Post: 27-09-13, 07:05 PM
  4. Linksys E4200: Internet gets low after enabling QoS and WMM
    By ScienTist in forum Networking & Connectivity
    Replies: 4
    Last Post: 22-04-12, 03:34 AM
  5. Download Internet Explorer 10
    By john in forum Internet & Web Browsers
    Replies: 0
    Last Post: 14-12-11, 12:30 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


About TechDiscussion

    TechDiscussion.in is an Open Source Community to provide latest information from Technology World, provide instant help for users tech related issues, we provide free downloads for your Computers, Smartphones, and more...

Follow us on

Twitter Facebook youtube RSS Feed Flickr DavianArt Dribbble